Structure Viewers
Take a Class
This guide supports the Galter Library class called Structure Viewers. See our Classes schedule for the next available
offering. If this class is not on our upcoming schedule, it is still available to you or your group by request.

Uses for Structure Viewers
There are many software packages for viewing molecular structures available for purchase or as free software downloads
on the Web. Some structure viewers are good for viewing individual or multiple structures, while others provide more
options for analysis of structure features. Others are best for creating publication-quality images.
This guide demonstrates the use of two structure viewers: NCBI's Cn3D and SwissProt's Deep View (also known as
SPDBV). Users will learn where to download both viewers, how to use them for aligning similar structures, how to import a
sequence to align to a structure and how to edit a structure's displayed characteristics.
The beginning of this guide offers a brief introduction to the Protein Data Bank, where users can download structure files.
The end of this guide provides users a link to download Pymol, a structure viewer that creates excellent publication-quality
images. A list of other structure viewers is also located at the end of this guide.

Finding Structures at the PDB
The Protein Data Bank (PDB) is the official world wide repository for molecular structures.
Search the PDB by
Text keyword (such as a description of the molecule)
PDB identifier
Author name
Chemical name
Chemical identifier
This guide uses the example of "NK ly49" to search for natural killer receptor Ly49.
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You can also click on the Advanced Search button and perform a guided search by specific field in the PDB record. The
advanced search is also where you can paste a sequence and perform a BLAST against the structures in the PDB to see
if a structure exists with similarity to your sequence.
In your search results page, you can refine your results by removing redundant structures using options to decrease
sequence similarity. You can also sort your results by
PDB identifier
Release date (this is the default display)
Residue count
Structure resolution
Select a structure record by clicking on the PDB identifier or the description of the structure.
On the PDB structure summary
View summarized details of the structure, such as release publications, species information, chain information
Use the tabs at the top of the page to view detailed information on protein families, experimental conditions and
geometry or perform sequence or structure similarity searches
View images of the structure
Use PDB's options of structure viewers to see your protein. Jmol is the recommended default.
Note: Jmol is a Java-based application and will open in your browser window. Jmol is a very user-friendly
application and allows you to view the structure in many ways. Users are encouraged to explore the features
of Jmol, since this guide does not cover this viewer.
Download files using the links near the upper right of the summary page (next to the PDB identifier)
The drop-down Download menu offers many options for file formats. Usually the .pdb files will be the most
compatible with most structure viewers, but other formats are available.

NCBI's Structure Database and Cn3D
Structures can be searched in other databases besides the PDB. You can search for structures at the NCBI, as well.
Cn3D is a structure viewer created by the NCBI. It is the default structure viewer for opening structures from NCBI's
Molecular Modeling Database (MMDB).
To use Cn3D, you must first download the software onto your computer. Download links for Cn3D are located at multiple
places in the structure search results, structure summary pages and from the NCBI's structure home page. Here is a direct
link to the Cn3D download page.
On the NCBI home page, use the pull down menu above the search box to select Structure
Type your search terms in the box
Again, this example uses NK ly49
You can also search by PDB identifier number, if you know it
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Your search results page will display thumbnail images and summaries of all results.

From the results page, you can
Refine your search using limits
Link to protein families or superfamilies
Link to literature citing the structure
See if your results include heterogeneous structure complexes
See species distribution of results
Use the links to related structures, domains and other links
Click on the PDB identifier to view an individual record (this example uses 1P1Z)
From the structure summary page, you can click on the image of the structure to open it with Cn3D (if you have Cn3D
installed on your computer--if not, you will be directed to the Cn3D download page).
For chain-specific structure comparisons, scroll down the page to the section showing the structure domain schematic
images.
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From this view you can
Link to the protein records using the Protein links
Click on the colored bars to access records in NCBI's Conserved Domains Database for families and superfamilies
Families are shown in darker colors and are located above superfamilies
If a chain of your structure contains more than one domain, all domains will be arranged along the sequence
bar
Click on the Sequence bar to access an alignment of structures that have similarity to that particular chain
For this example, click on the Sequence D bar.
NCBI's VAST Related Structures
You are now on a page showing results from NCBI's VAST (Vector Alignment Search Tool) Related Structures search. On
this, you will see a number of red bars aligned to your query sequence graphic. The results of this search are not limited
to a specific family (such as natural killer cell receptors in this example) but will likely suggest members of a related fold
class or superfamily.
To display multiple structures aligned to each other, click the checkboxes next to a few of the VAST results (the limit is 9)
and click the View 3D Alignment button at the top of the page.
Viewing Structures with Cn3D
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You are now viewing a multiple structure alignment in Cn3D. Cn3D will open two windows: a structure view window and a
sequence view window. The style of the molecules is different from what you would see by opening any individual structure
directly from its Structure Summary page at NCBI. The color shown is based on identity of amino acids, with red
representing identical residues across the structures and cooler colors (such as blue) representing less similar amino
acids. Note that, despite the low degree of sequence identity, the structural alignment is fairly good.
With Cn3D you can modify the view of your structure(s) in many ways:
Click and drag your mouse on the structure view to rotate the molecule(s)
Hold down the Shift key and click and drag your mouse to slide the molecule(s)
Hold down the Control key and click and drag your mouse to zoom the structure(s) in or out
View menu
Zoom in or out
Reset the view or restore it to its original view
View each frame separately (with a multiple structure alignment, each frame is an individual structure
Play an animation of the frames
Show/Hide
Pick individual structures or chains from structures
Show everything
Show aligned domains (the default view when opening Cn3D from a VAST page)
Show aligned or unaligned residues
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Show selected residues or domains (you need to select them from the image or the sequence window)
Show structural features within a certain angstrom distance
Style
Edit the global style
Within this pop-up window, you can change how features are shown or colored, as well as change the
background
Favorites (only works if you have created a custom style and want to use it)
Rendering Shortcuts
Worms (the default style if you are viewing an individual structure)
Tubes (the default if you are viewing an alignment)
Wire
Ball and stick
Space fill
Toggle side chains (to be visible or invisible)
Coloring Shortcuts
Secondary structure (the default if you are viewing an individual structure)
Aligned
Sequence conservation
Identity (the default if you are viewing a multiple structure alignment)
Variety or weighted variety
Information content
Fit
Object (each structure is an object)
Domain
Molecule (each type of molecule in a class will be the same color)
Hydrophobicity
Charge
Temperature
Element
Annotate to create your own custom style for a highlighted section
Window - allows you to display or hide the sequence viewer and message logs
CDD - only available if you have opened a family from a CDD page
Help
From the Sequence/Alignment view window
View menu
PDB titles (default)
Geometry violations
Find a specific Prosite pattern
View or hide rows
Show a Position-Specific Scoring Matrix (PSSM) score upon mouse-over
Show self-hits from database similarity scores
Export sequence alignment in FASTA or other formats
Show a taxonomy tree
Edit
Enable or disable the editor (you must enable the editor to make changes from the Edit menu)
Manipulate blocks by splitting or merging
Sync sequence colors to structure colors
Sort or delete rows
Mouse mode - choose to select sequences by rows, columns, click-and-drag horizontal boxes (default)
Unaligned justification
Imports - manage an import wizard so you can import other structures or sequences
Click Show Imports in the Imports menu
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Now click on Edit and pull down to Import Structure or Sequence
Now you can import a file from your computer or use the Via Network option to search NCBI for a structure
The drawback here is that you must know the MMDB ID number from the NCBI's MMDB, and you can't
use a PDB identifier
Try importing structure number 12071
You may have to do some editing of your imports to get them to fit your current structure
From the Alignments menu in the Imports window, select Block Align Single and click on the
sequences to align
A new window will open
Click OK
Now from the Alignments menu, click on Merge All
Now close Cn3D but reply Yes to all of the save prompts and save your new file to your desktop
Now re-open the saved file. Some error messages may pop up, but your alignment should be visible.
If it's not, go to the File menu in the structure viewer and choose Realign structures

Above is a screen shot of the new alignment with the new structure added and highlighted in yellow.
Cn3D produces decent quality images, so you can export your images by going to the File menu and selecting Export
PNG.

The Swiss Protein Data Bank Viewer (SPDBV) DeepView
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Also known as Swiss-PDB Viewer.
DeepView has an interface that allows the user to make measurements, compute energy and change the structure of a
molecule.
To download Deep View to your computer, go to the Deep View home page and select Download from the left menu bar.
You will have to agree to terms of use to download the software. The software is downloaded as a zipped file, so you will
have to unpack the zip file and save it to your computer's Program Files (or Applications for a Mac). Be sure to create a
short cut to the program on your computer's desktop or in another location where you can find it easily.
Importing Structures to SPDBV
Open DeepView. You can close the About window so you only see the toolbar when you open the program. From the
File menu, you can open any .pdb, mmcif or MOL (SDF) file that you have saved on your computer.
You can also use the Import command to search your computer for PDB files. The import window also allows you to use
an Internet connection to search PDB for a particular PDB identifier. You can also search for PubChem IDs or paste a
sequence in the window to model.

When you import a structure, sometimes structural data is incomplete, so Deep View will attempt to create side chains or
other missing data. If this happens, a dialog window will open showing you all of the edits that the program made. You
can close this window after viewing the information.
For this guide, use the PDB identifier 1P1Z and click the PDB file button in the Grab from server section of the menu.
This is the natural killer cell receptor Ly49.
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The Menu Bar in SPDBV

The pull-down menu bar in Deep View contains many options. There are too many options to list separately in this guide,
so only a few will be demonstrated, but you can explore more functions as you become more familiar with the viewer.
The quick options are displayed as picture icons in the menu bar. These are some of the frequently-used features of the
browser.

Center - Click this to re-center your structure after resizing the window or adding more structures
Drag - Click this to use your mouse to drag your structure on the page without rotating it
Zoom - Click this to use your mouse to zoom in or out
Rotate - This action is the default when you open Deep View, but you can click on this after using the drag or
zoom buttons to return to rotate action mode
Measure - Click this button, then use your mouse to click on any two atoms in your structure to measure the
distance between them
Angle - Click this button, then use your mouse to select three atoms on the same side chain or portion of the
backbone to measure the angle between them
Dihedrals - Click this button, then click anywhere on a particular amino acid to view its phi, psi and omega
angles
Provenance - Click this button, then click on an atom to display its molecule, group, chain and atom
Display or hide a group of atoms that are a specified distance from a selected atom
Center the view on a selected atom
Click this button to fit a molecule to another one (only available when more than one molecule is on the
screen)
Mutate - Click this button, then select an amino acid. A menu will open that will allow you to select another
amino acid to mutate to, along with an option to predict the probability that this mutation will preserve the secondary
structure
Torsion - Click this button, then select an angle on a side chain or the backbone of the molecule. You can
then rotate any portion of the structure from that point to the C-terminus. You will also be warned of potential steric
clashes resulting from torsional rotation.
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For more detailed descriptions of these quick button options, view the help document which can be accessed by clicking
the small question mark (?) next to the buttons.
After you have opened a structure, open the Control Panel by selecting the Wind menu then selecting Control panel.
From the control panel, you can make changes to entire chains or whole structures by using the columns.

The default structure view is a wire structure, so to view either space fill or ribbons, use the columns marked ::v or ribn to
change the view. You can then set preferences for the ribbons using the Prefs menu in the viewer window.
Aligning Structures in Deep View
Import a second structure into your window using the Import option in the File menu. Try importing the PDB ID 1GZ2.
This is a chicken egg shell protein (not a natural killer cell receptor).
When working with two or more structures, each structure is in a separate layer in the display. Toggle between layers by
clicking on the structure ID in the control panel and switching to another layer by clicking its identifier.
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To make your alignment easier to interpret, color the two structures by layer. In this view, 1P1Z is yellow and 1GZ2 is blue.

To align structures, you can use the button in the menu bar, but a better way to generate a structural alignment is to use
the Fit menu.
Magic Fit will provide a good, fast fit for somewhat similar structures
Iterative Magic Fit moves through the structures adjusting the alignment iteratively
Explore Fragment or Explore Domain Alternate Fits will perform more slowly than the Magic Fits, but may work for
structures that share only small regions of structure similarity
Select Magic Fit, and a dialog box will pop up.
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You can choose what parts of the structures to align, and which structure will be the reference layer. Click OK. Now your
structures will align.

To make the two structures more easily viewed, remove the other chains from 1P1Z from the view and change the
rendering to ribbons. You can do this from the control panel by selecting only chain D from 1P1Z, then selecting ribbons
for both structures.
Then you can select Improve Fit from the Fit menu. Now you can see that some of the major structural features (beta
strands and alpha helices) are aligned.
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You can use the many options from the other menus to explore your structure.
Open the sequence alignment window by clicking on the Wind menu, then selecting Alignment. This way you can see
residues selected in both the sequence and the structure.
Use the Select menu to highlight accessible residues, neighbors of a specific residue, protein clashes and many
other options
Use the Build menu to add residues, remove residues, break or ligate a backbone (especially useful when you are
mutating residues and exploring alternate backbone torsion angles), build loops and more.
Use the Tools menu to measure energy, electrostatic potential or molecular surface
Use the Color and Prefs menus to specify coloring or rendering preferences
Use the SwissModel menu to upload a sequence to model against a structure, work with that model, or submit a
model prediction job to the SwissModel server for a more computationally rigorous structure model prediction.
Use the File menu to save an entire project as a .pdb file, so you can open it with other structure viewers, or come
back to it to continue your work

Other Structure Viewers
Many other excellent structure viewers are available for free download by users.
RasMol has an open source version that all users can download. It produces colorful but slightly lower quality
visualizations than some other viewers.
Jmol is a Java-based structure visualization application that is very user-friendly.
VMD (Visual Molecular Dynamics) is an extremely powerful structure visualization application that allows for a great
deal of computational analysis.
PyMol - the popular modeling software formerly free to all is available for a fee
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Resources and Help
Tutorials and help documents exist for PDB, Cn3D and Deep View.
PDB's Education resources (PDB 101) page
NCBI's MMDB help page
NCBI's Cn3D tutorial
NCBI's VAST help page
Swiss PDB Viewer (Deep View) tutorial
Tutorials and help pages can also be found for most of the structure viewers listed in the section above. They usually can
be accessed from the home pages for the viewers.
Many of these structure viewers also have user wiki sites, which can be found on their tutorial pages.
You can also get assistance in using many of these viewers from the Biosciences & Bioinformatics Librarian.
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